~Kristo am 02.01.2014 22:18 #12102

Hi! I tried to play maps bigger than 256x256, for example my map was 896x896 and it worked fine when playing alone against ai, but as I wanted to play it with a friend, it just freezes at the loading screen.
Would it be possible to fix this somehow and will there be some problems appearing later in the game like sprite(unit) limits or something? Thanks!

Spike am 03.01.2014 00:55 #12104

Im Ruhestand
This is not a bug - this happens because the mapfile is sent using your internetconnection. A 900x900 maps is
around 7 MB big I guess, this needs some time when loading everything. You may wait a bit longer or send the
map to your friend and save it in your player folder.
RttR was never built to include maps that large, it's more like luck that it works.

There are no limits in the late game but maybe it will get laggy as hell as you have a lot of pathfinding
which is slow.

Also I'm interested in that mapfile, may you send me this file?


~Kristo am 05.01.2014 20:07 #12131

Yep, I tried to copy the map to his computer, but still the same thing. The map is mainly a test map, it´s not very pretty, but here´s the link
the map size is 928x928 and around 12mb.

Spike am 05.01.2014 20:17 #12133

Im Ruhestand
where did you put this map? "C:Users\Spike\Saved Games\Return To The Roots\MAPS"


Editiert von Spike am 05.01.2014 20:18

~Kristo am 05.01.2014 20:18 #12134

The main purpose, if I could see that this size of map would act ok, would be making a map where you could start off slowly, maybe get some of the resources from little deserted islands and work your way through big jungle and finally do some battleing with ai. Maybe move all the goods and settlers on and leave the headquater and the old military buildings behind(or even destroy the old buildings).

~Kristo am 05.01.2014 20:20 #12135


~Kristo am 05.01.2014 20:21 #12136

C:GamesReturn to the RootsRTTRMapsNew

Spike am 05.01.2014 20:43 #12137

Im Ruhestand
No, thats the "New" folder and not the "Played" folder - use my direction, maybe it works :)


~Kristo am 05.01.2014 21:37 #12138

I checked, the map file was already there too, I tried to start the map from the second computer and it started like in a second, but if I create the game from my first computer then it will start for me, but the second computer just has the loading screen and the writing "AND LET´S GO". Well atleast we can start playing now and hopefully it will work til the end. :)

Spike am 07.01.2014 17:36 #12149

Im Ruhestand
Maybe your 2nd computer is really slow, I have no idea, but tried you map just a second ago and everything
loads fine.


Quorzom am 07.01.2014 21:03 #12150

I downloaded the map and tried to load it in the game. The first time it crashed my game. Then I closed some programs and
it loaded perfectly. To be honest, it took much longer than most of the other maps, but since it is an 11 MB file this
should be obvious.

This was tested with a ~5 year old PC, so I guess you'll need at least a mediocre computer to run this map. And I assume
you'll need quite a powerful computer when things get really, really big.

~Kristo am 08.01.2014 08:56 #12151

The funny thing is that my second computer is faster, the specs are
1.I5-4440,8gb 1600mhz RAM, 2gb Radeon 7770 GHz
2.I5-4670K,16gb 1600mhz RAM,4GB GTX 770 OC,
but yeah when I create the game on the faster computer(2nd) then it´s ok(there´s absolutely no loading time on both computers) and we´ve played this map about 8h and the frame rates are
1.~250 fps
2.~500 fps
I tested it again to create the game on the 1st pc and it took almost 10 minutes to load the map for the 2nd computer(at least it didn´t crash like I thought at the first place). But I´m happy cause everything runs smoothly for the both of us on the map created on the 2nd computer :)

Feel free to post in English!

Antwort schreiben

Security code:

  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?