andoru am 19.03.2014 03:45 #12504

First of all I would like to thank you all for your wonderful work on the port of this game. I've been an avid fan of the original game ever since my german friend introduced me to it!

Now onto my issue, it seems to complain that the video driver couldn't be loaded:
$ ./
checking for an update ...
creating symlink
lade "/home/andoru/.s25rttr/CONFIG.INI": fertig (0ms)
searching for drivers in ./share/s25rttr/driver/video/*.so
0 video drivers found!
Video driver couldn't be loaded!

ERROR: Das Spiel konnte nicht gestartet werden
An error occured: press enter to continue

I've checked and there's '' under that folder, so I'm guessing the path is wrongly set. Any way I can fix this?

~Gast am 19.03.2014 09:48 #12505

Ich hatte das Problem vor kurzem auch, leider kann ich mich nicht erinnern wie ich es genau gelöst habe. Ich meine aber es hing damit zusammen, dass ich eine 64bit-Version von Linux installiert habe. Wenn ich mich richtig erinnere musste man die 32-bit Version der Grafiktreiber installieren.

~Gast am 19.03.2014 09:58 #12506

Hab nochmal nageschaut, hast du die Pakete sdl und sdl-mixer (Arch etc.) bzw. libsdl1.2debian und libsdl-mixer1.2 (Debian, Ubuntu etc.) installiert?

Wie ich oben schon geschrieben habe, kann auch die 32 bit Version der Pakete erforderlich sein, da bin ich mir aber nicht so sicher.

andoru am 19.03.2014 10:56 #12507

I'm not sure if Google Transfail properly translated what you two have said but I'll take a risk:
Sorry for not specifying this in advance: I'm using CrunchBang Linux 32-bit (which is based on Debian) on a 32-bit CPU, so that's not a problem. I think there might be a problem with libsdl, as I have completely removed pulse, and that may cause it to misbehave. I'll try later and let you guys know if I succeeded, perhaps I'll compile libsdl myself, it if enables me to remove it's support for the cruddy pulse madness.

andoru am 19.03.2014 16:56 #12508

Nope, after compiling on my own, still the same error shows up. Also compiling SDL by myself fixed some problems with other packages so now it's all good. Any further help with s2rttr would be appreciated, or perhaps if anyone could point me to who is the linux maintainer, I could contact him or her.

Editiert von andoru am 19.03.2014 16:56

Spike am 20.03.2014 04:05 #12509

Im Ruhestand
Well, I guess maybe jh and/or Maqs could help - just join IRC and ask them (be patient) maybe they have an


andoru am 20.03.2014 16:45 #12510

Alright, I'll do that, thanks.: )

FloSoft am 21.03.2014 09:07 #12524


since I've found out that the ppa (debian package) build silently failed nearly the whole year, I've fixed that now.

So the launchpad PPA now has the current nightly for "precise" available.


andoru am 21.03.2014 18:31 #12528

PPAs don't work with Debian from what I remember.
What I found out is the fact that the video driver was built with the dependency on pulse, which I've removed from my system (and I don't want to install.
Also I downloaded the latest nightly from here:

andoru am 21.03.2014 22:29 #12530

Okay, after talking with jh on the IRC channel I finally managed to compile the game myself, however, it complains that I don't have the game files placed in the S2 folder (which I have), and also the sound driver still depends on pulse. Any solutions for those two, FloSoft?

FloSoft am 22.03.2014 09:04 #12531

you have to set --prefix=$abspath to compile the paths correctly.


andoru am 22.03.2014 19:48 #12537

The paths are correct, I just don't want it to depend on PulseAudio for sound, instead I want the sound driver to fall back on ALSA.
Also I tried another version of Settlers II Golden Edition and it worked, however, the game is very slow, uses 100% CPU and goes around 29-30FPS. Any reasons/solutions for that?

Editiert von andoru am 22.03.2014 19:49

Spike am 23.03.2014 03:21 #12538

Im Ruhestand
the game is very slow, uses 100% CPU and goes around 29-30FPS. Any reasons/solutions for that?

Most likely update your display drivers.


andoru am 23.03.2014 04:46 #12539

Nope, installed the latest drivers available trough Debian.
Anyway, the issue was fixed after I started the game again.
Now the only problem is the audio driver and me wanting it to fall back on ALSA.

FloSoft am 23.03.2014 16:10 #12540

yes its the libsdl we use from your system which is built against pulseaudio.


andoru am 23.03.2014 20:35 #12543

But I compiled SDL without PulseAudio...

FloSoft am 24.03.2014 14:05 #12547

Do you have built libsdlmixer without pulseaudio too? since thats the one linking against pulseaudio.

And check if its using the correct sdl library (ldd driver/audio/


andoru am 24.03.2014 15:53 #12548

Argh, that was the problem, thanks!
I compiled everything and now it doesn't depend on pulse anymore.
But now the slowness returned, and I really have no idea why. I tried removing the audio driver from the folder and that didn't do anything, so it isn't the audio driver's fault.
I lauched the game from a terminal but I doesn't show anything in particular, or any errors for that matter.

FloSoft am 24.03.2014 17:21 #12549

hmm mostly it depends on your graphics driver - you can test to disable (or enable) "VBO" in the options (and restart the game) sometimes its better with, sometimes better without


andoru am 25.03.2014 15:34 #12559

It was previously disabled, and I enabled it but it hasn't fixed anything.
But I took a look over the configuration log of SDL and it seems that it wasn't built against directfb, so I'm guessing that might cause my problems. I posted a thread on SDL's development forums to see if I can fix this issue.

Feel free to post in English!

Antwort schreiben

Security code:

  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?