Forum



CrazyL am 24.07.2016 22:43 #14227


I've been looking forward to trying out these LUA-commands. My first test was to (re-)write a script for the first mission of the original roman campaign. If you find any bugs or weird behavior, please post it here! The missions should be fully playable, though some quirks still remain (consult the lua-files for details, especially MISS206.lua and MISS208.lua). So far, we have:

Version: v0.4
MISS200.lua
MISS201.lua
MISS202.lua
MISS203.lua
MISS204.lua
MISS205.lua
MISS206.lua !No complete testplay yet!   Error in map MISS206.WLD!
MISS207.lua !No complete testplay yet!
MISS208.lua !No complete testplay yet!   Error in map MISS208.WLD!
MISS209.lua !No complete testplay yet!

While testing I gained information about some RTX-commands not mentioned on Merri's S2-page or somewhere else (though some parameters are still missing...): s2_RTX_commands.txt

Edit (24.07.2016): Marcus wrote a script to generate lua files from the original RTX files, check out his work as well!

Edit (30.07.2016): v0.2: Set all AI to hard mode

Edit (03.08.2016): v0.3: Add all computer barriers

Edit (07.08.2016): v0.4: fix onContact-messages, fix messages in MISS204.lua, fix incorrect linebreaks in mission texts


Install:
  • Copy MISS20X.lua to the folder "%RTTR_INSTALL%/DATA/MAPS" (%RTTR_INSTALL% is your install folder, X the mission number)

  • Start "Single Player -> Unlimited Play -> Campaign -> ...

However, there are still a few things to do:

  • show the appropriate hints in the post box

  • add some animals (some were added by the original scripts)

  • make sure the missions can only be played in order

  • change AI behavior in game (friendly at first -> aggressive) / set one-sided treaties by script

As I got a few free days now, I plan to write scripts for the other missions of the "Roman Campaign" as well. I'll upload them as I make (and test) them, so stay tuned. Now that I learned how to save/load mission states and achievements, I might even get going on the FANpaign :)

Finally, thanks a lot to all who implemented lua-scripting and Spike especially for his inspiring videos!

Editiert von CrazyL am 12.08.2016 12:54

Spike am 25.07.2016 14:58 #14232

Im Ruhestand
Video Playthroughs:

I - Off we go
II - Initial contact
III - The pass
IV - On the high seas (German audio)
V - In the wasteland (German audio)
VI - Divided country (Bad audio)
VII - The snake
VIII - Sea routes
IX - The Gray Island
X - The Last Gate

Hi CrazyL,
Thanks for your work! I wanted to record a RttR Miss200 Video but -
sadly I ran into a problem.

If you reach the northern flats before you are given the task, you
wont complete that task, thus never get a farm or something similar.

---


Editiert von Spike am 04.11.2017 23:01

CrazyL am 25.07.2016 17:15 #14233


Hi Spike, sorry for that, I wanted to make the last two events (finding+activating the arc) independent from the rest, but forgot about that in the end... IIRC the original mission had that problem with the farm as well - if you expand fast, you will never get the messages about the mill, pig farm, bakery and slaughterhouse, just what you experienced. I never knew they existed before I started looking into the RTX-files: Guess I had patience problems back then and just wanted to reach the arc ;)

I'll be sure to change that in the next update (probably this evening)!

BTW: Do you know if you can set the "ingame hints" in the post menu (last button to the right with a briefing paper)?

Edit: I was wrong about the original game -- see my comment below!

Editiert von CrazyL am 02.08.2016 17:19

Spike am 25.07.2016 17:40 #14234

Im Ruhestand
Nope sorry, never used those buttons.

And I guessed that it also worked that way in the original, sadly :-/

---


Editiert von Spike am 28.07.2016 16:51

CrazyL am 25.07.2016 20:37 #14237


Updated MISS200.lua. I disabled barracks during the time where you find iron ore / build iron smelter etc., so you can't expand too early anymore. Tested that feature, should be working now.

From what I saw in the original game, they could only disable buildings before start and did not have that possibility...

Edit: Added the rest of the mission scripts, though I only checked that they load correctly. Now let the testing begin :D

Edit: As computer barriers are still missing, missions IV, VI, VIII and IX get MUCH harder because the AI can beat you by getting access to harbor points first. IV can still be won without any harbors - you just have to play extra conservative because you don't have access to iron that way, so you can't afford to lose many soldiers...

@Spike
Wow, I just saw your playthrough of mission one - that's awesome!

Zitat:
IIRC the original mission had that problem with the farm as well - if you expand fast, you will never get the messages about the mill, pig farm, bakery and slaughterhouse, just what you experienced.

I've been wrong here - I did a testrun with S2. In the original game the messages about reaching the northern lands and getting the farm are just kept back until you build the iron smelter, smithy and the iron mine. I guess I just never did that because you have enough soldiers to reach the arc without extras. Patience problems, like I said :D

I guess in the original game the event !MET_ON_OCCUPIED is called not only when you JUST occupied a place - it only checks if that place belongs to your land.

Editiert von CrazyL am 29.07.2016 12:04

Spike am 29.07.2016 12:35 #14243

Im Ruhestand
One request: Could you set the AI to hard instead of easy?

---



CrazyL am 29.07.2016 23:54 #14244


I have used strong AIs in missions VII-X, medium AIs in missions IV-VII and easy AIs in the first three missions to have some progress of difficulty.

I'll change the AI to hard in my next update if the missions are too easy right now. However, from what I've seen they were even easier in the original game. In my opinion the AI in the original game was even more peaceful there than the easy AI in RTTR...

Update: Changed all AIs to hard mode

Editiert von CrazyL am 30.07.2016 11:51

Spike am 31.07.2016 15:13 #14248

Im Ruhestand
Started playing Miss203 (I really loved that mission so I played it quite often) and ran into several problems:

Yellow AI NEVER occupied this area (guess it was blocked, although it occupied this area after you landed). Also the yellow AI never
occupied the northern pass (not even after 4h+)
https://picload.org/image/rropiodg/s25client2016-07-3114-45-34-99.png

Red also never crossed this line(They already went out of stone at this point):
https://picload.org/image/rropioip/s25client2016-07-3114-45-37-91.png

And the AI wasn't able to build ships, or at least didn't build any:
https://picload.org/image/rropiopr/s25client2016-07-3114-45-40-25.png

And as I dislike testing it in the original game, I just did that:
Yellow did not occupy the north:
https://picload.org/image/rropicdr/dosbox2016-07-3115-02-09-42.png
But occupied the lower spot (not visible here, see minimap) but did NOT build a harbor building.

Red got a bit further than I marked:
https://picload.org/image/rropicaa/dosbox2016-07-3115-02-29-60.png

Same in the next test:
https://picload.org/image/rropical/dosbox2016-07-3115-05-31-10.png
https://picload.org/image/rropicac/dosbox2016-07-3115-05-36-11.png

And in the lst test:
https://picload.org/image/rropicoa/dosbox2016-07-3115-07-47-44.png
https://picload.org/image/rropicaw/dosbox2016-07-3115-07-38-18.png

Guess you should work with restricted areas and the AI shouldn't be able to build a shipyard/harbor building.

---



CrazyL am 31.07.2016 21:31 #14249


@Spike that's because I deleted all computer barriers after we found a bug in
Code:
SetRestrictedArea()
. Although without barriers this mission gets a LOT harder and turned into a race for islands with the yellow player ;)

Although I mentioned the missing computer barriers in the headers of the lua-files, I sadly forgot to mention that here. Now it's done and I'm sorry for the inconvenience...

However, now that
Code:
SetRestrictedArea()
has been fixed (and I finished a conversion tool between

!GLOBAL_SET_COMPUTER_BARRIER R X Y

and the corner points of the resulting polygon in that crazy non-rectangular coordinate system), I'm sure I'll have those computer barriers back soon.

P.S.: I actually thought it was funny - while test-playing that mission I suddenly couldn't explore in some directions anymore. Then I saw an enemy ship and only thought "What the?!? The AI has learned sea-faring??? Oh, it's RTTR, not old S2! Damn - I need to hurry to at least get that golden island..."

Editiert von CrazyL am 31.07.2016 21:43

Spike am 31.07.2016 21:57 #14250

Im Ruhestand
SetRestrictedArea() works for one polygon, but not for multiple, it would work for the purpose of miss203 as you only set area where
the AI should build, so no reason to first enable the whole map and then disable some parts but only enable the area where the AI
should build in.

And yeah, if you know you have to race... but I just started recording a video and took some time (are sea attacks enabled? I guess
not) so if you lose the race, you nearly lost the whole game as the AI is also faster in the north than you.

---



Flamefire am 02.08.2016 00:26 #14251


Spike: This is not completely correct: You can add multiple polygons. This is even detailed in the wiki (separate those polygons by 0,0 pairs)
I'll implement the option to display the blocked area in the map-debug view soon. This should help you map-devs :)

---
Github: https://github.com/Flamefire


CrazyL am 02.08.2016 12:18 #14252


I tried specifying multiple polygons (to create a hole) in a test map and it worked just fine!

@Flamefire I'll look forward to that option - keeping track of multiple barriers right now is getting confusing, especially if you create holes with them ;)

Editiert von CrazyL am 02.08.2016 12:21

Palatinus am 02.08.2016 15:07 #14253


I love the old campains and a view weeks ago I've started to play the old campains in dosbox. I would love to play them in RTTR.
Therefore I would like to help by testing the maps.

I like Spike's idea to record the test in a video. So everyone can see what has been testet. Should I do that or just test for my self?
How can I
help without programming?

Editiert von Palatinus am 02.08.2016 15:18

CrazyL am 02.08.2016 17:17 #14255


Hi Palatinus,

thanks, it's great to see that people still play the old campaign! By the way, you can already play the Roman Campaign in RTTR, the first four missions have even been tested. And if you post any bugs you encounter in the missions here, that would be a great help already! Especially since you just played the original ;D

@Spike I fixed the computer barriers for MISS203.lua (Mission IV). Took a while, because I got a few strange bugs while testing, until I realized that the computer barriers in the original game overlapped... and those overlapping areas the AI was of course allowed to conquer!

Now I know what to look for, I hope to get the rest of the barriers done today.

Editiert von CrazyL am 02.08.2016 17:24

Spike am 02.08.2016 17:29 #14256

Im Ruhestand
I'm sorry for any confusion @Flamefire @CrazyL I may caused, Just wanted to say that a original alike behavior was
possible even with the buggy barrier version as you don't need create holes but could use one big polygon! :)

Nice, are restrictions lifted upon reaching one of the points for the corresponding AI? Maybe they conquer you ;) Also is
seafaring disabled for AI players? (Sorry for asking, can't take a look at the code for now).

---



Flamefire am 02.08.2016 18:31 #14258


Spike and CrazyL: I pushed the update today that requires you to define 'getRequiredLuaVersion()' (currently should return 1) So you may need to update the lua scripts accordingly. This should ensure that your scripts won't break unexpectedly when the API changes.

---
Github: https://github.com/Flamefire


CrazyL am 02.08.2016 19:34 #14259


@Flamefire
That's great, thanks for the notification! I followed the changes on github (getRequiredLuaVersion() is already integrated in all the scrips) and I'll test it immediately.

@Spike
No, I don't lift the restrictions on contact, though that's an interesting idea. But I did disabled the AI's harbor and shipyard, so that would be an option!

By the way, I did some testruns with S2 to get more info on !GLOBAL_SET_COMPUTER_BARRIER (see s2_RTX_commands.txt) . It turns out, in S2 the barrier doesn't completely block the AI (as SetRestrictedArea() does), but it merely prevents the AI from building military buildings in the blocked areas.

Editiert von CrazyL am 02.08.2016 19:43

Spike am 02.08.2016 21:49 #14260

Im Ruhestand
@CrazyL - Agreed, thats what I also think it's like :)

---



CrazyL am 03.08.2016 01:54 #14261


Added computer barriers for all missions (and tested them via replay) and disabled AI's sea-faring in missions IV, VI, VIII and IX -- now all missions should be fully functional!


Palatinus am 03.08.2016 12:14 #14264


I did not play all missions in dosbox. I am at the end of mission 5. I will play it to the end in dosbox and then replay in RTTR.
Then I can tell the difference.


CrazyL am 03.08.2016 16:13 #14267


Hi Palatinus,

have a lot of fun playing:D And if you find some differences, we'll look forward to your remarks!


Palatinus am 03.08.2016 22:44 #14273


The Second Message I've got in Mission 5 has 2 Bugs.

First: The LF is missing. Therefore the window is too big and I can't read the text:
https://s31.postimg.org/b8wugr1hn/d002.jpg

Second Problem: This message should be the third message but it came second. I've
played a little differnt than in dosbox so I don't know if that problem would also accure in the old version. I belive so because I
think the script-evnts are triggert by simply 'seeing the player'. I remember that the scripts in S2 sometimes where strange... :-)
But: In my last dosbox game a view days ago it was differnt. I've replayed the mission in rttr a little bit different and then the
scond message appeard before the 3th message:

https://s31.postimg.org/v1badc9u3/image.jpg
LF is also missing.

I think the scond bug is not a real bug but a conecpt problem on how the scripts trigger the event. So that is ok for me.

Editiert von Palatinus am 03.08.2016 23:09

CrazyL am 04.08.2016 08:49 #14274


Hi Palatinus,

thanks for your help! I fixed the mission statements in mission V, forgot to set line breaks in that mission:(

Concerning the "onContact" messages when you meet a player: I only check if territory the player explores is already occupied by the AI.

But if the AI occupies territory after you explored it, there won't be a message... I think I'll rewrite the "onContact"-events to check if the AI explores player territory as well. Then those "onContact"-events should trigger on time.


Palatinus am 04.08.2016 12:22 #14283


What about this:
In the Mission we all should be firends. The first view missions you always have peace with the computer players so you can choose
the time to attack. This is vital for game experience and strategies you can use to play.

But the game is set in a way that the computer is my enemy:



Also there is a button for deplomacy where I can ask for peace...


I fear that this is a real problem. Can this be changed by scripts or is the "peace untill attack" function not available in RTTR?


Palatinus am 04.08.2016 12:26 #14284


You know in the original game in the first missions you can use the catapult to attack you enemy without breaking the peace treaty. I
know that is stupid and not realistic. But that is how the game works.


CrazyL am 04.08.2016 13:43 #14285


Hi Palatinus,

thanks for your feedback! Right now we don't have the possibility to change diplomacy settings in-game by scripts, because the AI does not react to the player asking her to change the diplomacy. We discussed that function in #517 (last few comments) and I look forward to using it. As for the "peace button": You only ask the AI to sign a peace treaty/break it. As long as she does not react to these offers, you stay her enemy no matter what you do in the diplomacy settings!

That said, right now the AI must be your enemy from start because otherwise you could never attack the AI, as she does not react to your proposal of breaking the treaty. No catapult bombing for free anymore (at least for now) :(

Editiert von CrazyL am 04.08.2016 14:03

Palatinus am 04.08.2016 14:05 #14286


OK, bad news but that is what I expected.

I've got an even bigger problem:


(3) The red player is expanding so fast and is building castels that I can not win this mission. I think the original Mission 5 is
not too hard. But I just can't seem to win this one. Even if it is differnt from the orginal (and because of the diplomacy problem) I
suggest you add a 'not crossing line' for the red player in this mission. You should place it left next to the enemy castle from the
screenshot.

(2) The red player is building castles all the time. In S2 the player build much less. That makes it even harder but I think that is
ok.

(1) The yellow player is not getting any gold. That's differnt in S2


Palatinus am 04.08.2016 14:13 #14287


And here is my last post for today:


Am I still helping or is this just too much?

Edit: Sorry for the bad spelling in english.

Editiert von Palatinus am 04.08.2016 14:15

CrazyL am 04.08.2016 15:45 #14288


Hi Palatinus,

nope, every critism is fine by me (and just for your information, I'm German, so I expect there'll be a lot of typos in my replies as well ;))

I replayed Mission V, just to check it out. Regarding your last picture, I guess you were unlucky: In my replay, the yellow player expanded normally, so he and the red player shared the mountain with the gold just behind that narrow passage where you normally meet the red player.

The yellow player still had hardly any gold, but that's because he ran out of boards somehow. That seems to happen sometimes with the AI. I could have taken the upper route through the "stone curtain" and defeated just the yellow player.

Regarding all those fortresses, that might be because I set all AI players to hard (requested by Spike some posts ago, to add a little challenge ;) ). However, I ran into a weird bug where the gate had disappeared because the yellow player had built something right next to it?!?

Editiert von CrazyL am 04.08.2016 15:49

Palatinus am 04.08.2016 16:04 #14289


For your bug you could change the the landscape of the map so nothing could be build there. I will stop playing missing 5 in RTTR and
continue with mission 6 in S2/DOSBOX. Please leave a comment when you made changes to the lua. Then I will replay mission 5 in RTTR.

Editiert von Palatinus am 04.08.2016 16:04

Spike am 04.08.2016 18:29 #14295

Im Ruhestand
As far as I know those different AI strengths only affect actions/GF the AI does, means an AI on hard just takes more actions and is
faster than an easy AI.

---



Flamefire am 05.08.2016 01:47 #14297

CrazyL am 05.08.2016 13:53 #14302


@Flamefire
That is great (and fast!), thanks a lot!

@Palatinus
I already changed and tested the "onContact()" events for all missions so you get a "onContact"-messages if you explore AI territory or the AI explores your territory (though I haven't uploaded the changes yet). Flamefire and Spike work on the bug fix about the "disappearing gate" right now.

I'll try giving the yellow player more boards at the beginning so he doesn't run out so fast (yellow has NO trees at all at the beginning, that might be the problem here), I'll write again when I tested my settings there and uploaded the changes.

Edit: (@Palatinus)
I updated all missions to v0.4. In mission V, I gave the yellow player 50 logs extra at start, here are the result after two hours gameplay at normal speed (t in [1h; 2h]), immediately before winning the game:


This time, both red and yellow shared the gold mountain that lies just beyond the small passage in the middle of the map; now I'd say this mission is the first challenging one of the Roman Campaign, just like it was in the original game. I also tried your tactic, got rid of the huge stone wall in the north and had to fight the yellow player only :)

Editiert von CrazyL am 08.08.2016 11:01

Palatinus am 09.08.2016 08:05 #14316


@Crazyl:
That is great news! I'm almost finished with Mission VI in DOS. After that I will repaly V and VI in RTTR and
give you feedback. :-)


CrazyL am 09.08.2016 11:57 #14317


@Palatinus
Great, I'll do it the other way round and hope to get Mission VI in RTTR today. Let's see if we find some bugs there.

Just take care, now that the yellow player has access to gold, mission V got "a bit" harder. But it's not impossible, of course ;)

Editiert von CrazyL am 09.08.2016 11:58

Palatinus am 10.08.2016 12:36 #14318


I am playing Mission V in RTTR now and so far everything looks good. I still think you shold add a barrier for the red player in the
south because the red player is expanding much faster than in S2.


CrazyL am 10.08.2016 22:02 #14321


@Spike
I just watched your playthrough of mission III, that was great! By the way, did you encounter some lua errors? I noticed you didn't get any messages when you met the AIs (so you didn't get the lookout tower either...)

Also the yellow AI should not have been able to expand that far south when you met her at the northern pass together with the red AI (there should be a computer barrier)... I'll look into that!


Spike am 10.08.2016 22:22 #14323

Im Ruhestand
@CrazyL
Sadly I have no idea what actually happened in the original - I just sometimes randomly remember some facts but nothing in general :-/
Maybe I should check the LUA file after I tested your game (and output the game output to a file and check it for LUA errors). Also I
guess in Miss II I got the storehouse quite late and in Miss I I got the well message immediatly after the iron message so the iron
message was closed and I never could read anything about wells, also I couldn't build any donkey breeder, could I?

Checked that - no LUA error in any mission so far :)

---


Editiert von Spike am 10.08.2016 22:34

CrazyL am 10.08.2016 22:39 #14324


@Spike
Don't worry, I watched the videos with the script open to know what to expect and to notice any differences. I don't know all the events by heart either ;)

As far as I know, donkey breeders are completely disabled in mission 1 in the original (and don't get enabled anywhere). The missing "well"-message in is a bug of the mission statement windows in RTTR. In the original, they show the messages one after another if you activate more than one and don't skip the later ones. I think that bug was already mentioned.

The reason you got the storehouse later than usual in mission 2 is because in the original it got enabled via !MET_LAND_SIZE (a command that checks if your territory exceeds some value - something we don't have in lua). Instead, I chose a few landmarks. If the player occupied any of those, he will gain the storehouse.

Perhaps I should move those markers closer to the HQ. However, this mission should teach the player to build storehouses, and the best way is to show what happens if you don't build enough - so I'd leave it like that :D

P.S.:
I don't think we need "onLandSize()" in lua, because it's only used once in all ten mission and I don't see oppertunities where you need it because you can't use "onOccupied()".

Edit: On the one hand, that's great. I'll look into the onContact-messages and try to find the error.

Editiert von CrazyL am 10.08.2016 22:55

Spike am 11.08.2016 07:28 #14325

Im Ruhestand
Well - It's maybe not that great for mission but I think the script should be able to read all information shown in the statistics as
you may want to script a mission where you should have a specific landsize or where something happens as you grow or in multiplayer to
check something ("You are the greates lord, here, get some gold").

---



Palatinus am 11.08.2016 20:20 #14332


I've played mission V in RTTR in different ways. As expected there is still no gate at the end of the game. Besides this the mission is
harder than in original. But I really like it the way it is right now - more a challange. Even with the red player expanding realy fast
I found a way to use catapults in a way similar to the original.

So: When the gate bug is fixed the map is done! I will now start with mission VI.

Keep up the great work!


Flamefire am 11.08.2016 20:44 #14333


The gate bug should already be fixed with the latest nightly

---
Github: https://github.com/Flamefire


Palatinus am 11.08.2016 21:11 #14336


I had the latest nightly but I've started the mission before the fix. Most probably the enemy building was there before the fix was
installed...?


Flamefire am 11.08.2016 21:15 #14337


This is possible. You can check the replay if it is true (with 'D' you can disable the FoW)

---
Github: https://github.com/Flamefire


Palatinus am 11.08.2016 21:34 #14338


I'l try that. Is it right that the last nightly is 20160730??? Is that the Version with the fix?


Flamefire am 11.08.2016 21:50 #14339


No, thats the buggy one. I'll try to find out why the new one is not published.

---
Github: https://github.com/Flamefire


CrazyL am 12.08.2016 11:35 #14342


@Palatinus
Thanks for your kind feedback! Personally, I like the extra challenge the map poses now, and as far as I recall it was the first remotely challenging map in the original game as well. Right now I'm at the last step of mission VI in RTTR - let's see if I can beat the yellow player too :)

Edit: You thought Mission V was hard? Wait until you played Mission VI... I had to start over completely once and only pushed yellow back on my second try. But it is not impossible to win :)

Edit: Do you know if you can explore the harbor near the yellow player from start or do you get access to it only after you pushed back the red player and occupied his harbor place in the north east behind the mountain range?

Editiert von CrazyL am 12.08.2016 13:00

Palatinus am 12.08.2016 19:28 #14343


@CrazyL:
Yes I've noticed that the red player ist fast and has gold. :-(
I am working on it. :-)

I know that there are 2 harbors near the yellow player, the one in the south is the good one. But what does that
have to do with the red player?


CrazyL am 12.08.2016 19:46 #14344


@Palatinus
Good luck, you're going to need it :D

I guess I don't remember that mission well, it's been a while since I played the original mission VI... I thought that only ships that start expeditions from red player's harbor place behind the mountain (the one with the message) could "find" yellow player's harbor places.

In RTTR, your ships can find yellow player's harbor places right from the beginning, so you "could" ignore red player entirely...

Editiert von CrazyL am 12.08.2016 19:48

Palatinus am 12.08.2016 20:20 #14345


@CrazyL:
That is right. I've played the dos game a view days ago and at the beginning I could build a harbour directly next to the yellow player
(west of the yellow player) but I could not hold this plase. Too hard. The harbor in the south of the yellow player was not accessable.

I've tried it a view times. This mission VI in RTTR is to hard for me. :-( I just can't win against the red player because he gets to
fast to a place were he gets gold. For me it just takes too long to get some gold.

It is cool that you could win this mission. :-) But for the "non god like players" like me this is too much. By the way: I think the
dos Version of mission VI is really easy.

Editiert von Palatinus am 12.08.2016 23:35

Palatinus am 12.08.2016 20:33 #14346


@CrazyL:
I've modded your lua file to make it a bit easyer. I will try with this one. But it is your work, perhaps you
have a better idea?
I've marked every changed line with a comment.
Edit: Version2: https://dl.dropboxusercontent.com/u/2477297/tmp/MISS205.lua

@Flamefire:
Thanks for fixing the nightly build!

Editiert von Palatinus am 12.08.2016 21:59

CrazyL am 12.08.2016 21:34 #14347


@Palatinus
Feel free to edit, those resources were tested for the original AI so they may be too much for the improved AI in RTTR!

Let's see how much that helps. I think taking away some food will make the AI a little slower, but taking away some coal definitely helps. And the AI's have more than 60 soldiers at start, while you got only 20...


Palatinus am 12.08.2016 21:58 #14348


OK, I've reModded with you advice and will start my next test now


Palatinus am 12.08.2016 22:32 #14349


There is something strange. With your unchanged LUA File and the new Nightly Build now by default the red player
is the yellow player and the yellow player is the red player. I don't know if this is important because it can be changed at the
beginning of the game.

Version 20160812:


Version 20160730:


Editiert von Palatinus am 12.08.2016 23:38

Spike am 12.08.2016 23:29 #14350

Im Ruhestand
Sounds like I have to download those files now as I hate content that is nerfed :o

---



Flamefire am 12.08.2016 23:34 #14351


The player colors have changed as per the request in https://github.com/Return-To-The-Roots/s25client/issues/565

---
Github: https://github.com/Flamefire


Palatinus am 12.08.2016 23:37 #14352


Thank you Flamfire for the feedback. :-)


CrazyL am 13.08.2016 01:15 #14353


@Palatinus
Thanks for mentioning that, the scripts still use the old color order.  I'll change the colors tomorrow :)


Palatinus am 13.08.2016 20:26 #14354


Spike is right. The modification should be minimal. No changes on the human player and no changes for anything that changes the
statistics. Actually the values are good. The only problem is that the computer player is too fast. I've found an easy way to chance
that:

Code:

[GD_WOOD      ] =  70, --Palatinus Mod, Original = 0
[GD_BOARDS    ] =  20, --Palatinus Mod, Original = 90


With this 2 minor modifications the computer will still not run out of boards but is slowed down in the beginning of the game. I am
working now on optimal values so that the mission feels like in S2.


Spike am 14.08.2016 15:14 #14355

Im Ruhestand
I also finished the 5th mission and found some bugs (not really lua related).
- it is possible to attack without removing the stone barrier in the north (caused by a bug)
- stalagmite and stalagtite were non blocking
- some dead trees which should block were non blocking
- there was no gate at the end - but the message appeared

- upload will take some time as I needed quite some time to win this (due to that path bug I reorganized my defense)

Edit: found the gate-problem, the upper AI built a fortress immediatly after the beginning next to the gate which removed the gate :(
https://picload.org/image/rrcigolc/s25client2016-08-1415-16-52-21.png

---


Editiert von Spike am 14.08.2016 15:20

Flamefire am 14.08.2016 16:23 #14358


Spike: Could you document those bugs in Github as it seems this are game bugs? I guess there are some static objects that are handled like environment objects?
The gate bug should be fixed in that latest nightly.

Edit: Ahhh, found the bug. There was a 0 where a 1 should be :D Will be fixed about today I hope

---
Github: https://github.com/Flamefire

Editiert von Flamefire am 14.08.2016 17:51

Palatinus am 16.08.2016 22:20 #14376


Did you add a barrier for the yellow player. I was still testing several Board-Modification-Values when suddenly the (now) yellow
player stops to expand. Now it is almost to easy. I've changed back to your lua and I am using the current nightly. The baracks of the
yellow player are filld with soldiers but the land of the yellow player won't expand north.

Is this purpose?



Editiert von Palatinus am 16.08.2016 22:23

Palatinus am 19.08.2016 16:30 #14384


I will continue with the next mission untill I get a reply. :-)


Flamefire am 27.08.2016 10:44 #14387


There is a new update coming this weekend: https://github.com/Return-To-The-Roots/s25client/pull/577
It will introduce mission goal description and AddAnimal, so I think this now includes all features from S2 scripts.

Note: GetVersion() will be replaced by GetFeatureLevel() which returns a single value (minor version) because you need to provide the major version anyway so that had no use. This is actually an API breaking change but I'll not increase the major version unless you think this is required, because I don't think that function was used before.

---
Github: https://github.com/Flamefire

Editiert von Flamefire am 27.08.2016 10:44

Spike am 27.08.2016 18:10 #14388

Im Ruhestand

https://picload.org/image/rrpagawg/s25client2016-08-2718-08-39-08.png

7th mission is hard bugged as restricted areas are just fucked up

Edit: As I feared, that all other maps also have bugs, they do:

Mission 8:
https://picload.org/image/rrpagolc/s25client2016-08-2718-14-53-68.png

Mission 9:
https://picload.org/image/rrpagoco/s25client2016-08-2718-18-13-03.png

You also wrote this map has a bug, what kind of bug? Players are placed correctly unlike Mission 7.

Mission 10:
https://picload.org/image/rrpagooi/s25client2016-08-2718-14-01-62.png

---


Editiert von Spike am 27.08.2016 18:21

Flamefire am 28.08.2016 01:38 #14389


Note: The map debug window (F6 or so) can show the restricted area for a player, so you can test if it does, what it should

Also the new features have been merged

---
Github: https://github.com/Flamefire

Editiert von Flamefire am 28.08.2016 01:39

Stiefelriemen_Bill am 08.09.2016 04:18 #14392

404
Zitat von Spike:


Hi, I fixed the restricted areas:

MISS202.lua
MISS203.lua
MISS205.lua
MISS206.lua
MISS207.lua
MISS208.lua
MISS209.lua

Actually all of them were faulty because the upper left corner had always been left out in the first polygon, simply forgotten I guess. This did not allow the AI
players to have any territory on the upper left half of the map, except the areas that were actually intended to be restricted, hence everything was burned down
after the first expansion and the borders were left as fucked up as in your pictures. However, I only corrected this single issue, I did not check if the restrictions
were set correctly apart from that.
Anyway, right now these restrictions prevent the AI from gaining access to the areas at all, but I think in the original game the AI was only prohibited from
building military buildings in these areas, right? I'm not sure about this, though, at least I can't remember the AI building military buildings directly at the border
without expansion.

Zitat:
You also wrote this map has a bug, what kind of bug? Players are placed correctly unlike Mission 7.


The map is missing harbour spots, he describes the problem in a comment at the top of of MISS208.lua.


Palatinus am 23.09.2016 11:58 #14411


@CrazyL:
Are you still on the project?


Marthzion am 27.10.2017 22:24 #14701


Hi guys,

I would like to know if there is still somebody working on this project.
Is there a completely working lua script at the moment for the original campaign? If yes, I would like to download.

I just tried by myself to finish the work. But there is still the "one sided pact" missing. Maybe somebody could solve this somehow???

I would like to know if there are already lua scripts for the FANpaign or even the 2NDpaign.

If somebody need, I could upload my lua scripts for the roman campaign somewhere. But I only repaired the maps and added animals and the hints. And I confess: in a bad way, because I dont know much about the scripting. LOL
I think somebody else did it in the meantime much better.


Thats all for now


Flamefire am 27.10.2017 22:32 #14702


What do you mean by "one sided pact"?

---
Github: https://github.com/Flamefire


Marthzion am 27.10.2017 22:53 #14703


That the player can decide, when its time to attack.

At the moment it is not possible to attack the AI when you have chosen the same team in the beginning.
but... actually I did not tried it. Maybe I am wrong and its already working?


Marthzion am 27.10.2017 23:23 #14705


Do you know something about the Fanpaign lua scripts? Are there any?


Spike am 28.10.2017 11:06 #14707

Im Ruhestand
Well one sided pacts (AI does not attack the player but the player could attack the AI) are not available yet.

The fainpaign isn't done with lua but rtx or what ever that format was called so it's sadly not compatible :-/

---



Spike am 04.11.2017 23:03 #14717

Im Ruhestand
Played through all missions now.
Just wanted to discuss two things:
On the map "The grey Island" the script stated that there should be harbor spots but there were not in the original or am I wrong?
Couldn't find any at the spots noted.

On the last map, the AI moved across the hill to the north, I think this should be restricted as the original AI never did so (although
it may not have been restricted). Anyone who disagrees?

---



KaioKen am 04.11.2017 23:18 #14718


Alright, so if any1 wants to play the mission VII:The Snake you need a changed map, for some reason the Red(left) AI player doesnt have a starting point therefore isnt in the game making it a 1v1 instead of a 1v2.

1)Added Red's spawnspoint

Following changes are to be closer to the original:

2)Reverted the colours to the original(Red left--Yellow right)

3)Changed the restrictions of the lua script to give the red AI access to half of the top-left mountain's recourses(iron & coal)

4)Changed the width of fjord in the south to prevent the yellow AI from crossing and thus gaining access to the recourses of the mountain

---> MISS206.WLD and MISS206.lua  https://drive.google.com/drive/folders/0B-GRYdJITblnX2FBeGpRYmVGdkk?usp=sharing



Also if you want to play the mission IX: The Grey Island you'll also need a changed map. The 2nd AI player cannot use his Forresters, because the ground which covers his land wont grow any new trees. Which means he has only his 100 Boards from the HQ and another ca 20 boards from trees around his Fort. Making him run out of boards very early and thus being useless, hence getting stuck.
Now, as I said the reason behind it is: the ground doesn't support growing trees, i first thought somehow the properties of the ground tiles was changed by RttR somehow, but no. I checked the original S2 and also there the 2nd AI runs outta boards very early cause of the same reason. Apperently Blue Byte must have never play tested this mission once!! Not only cant you grow no new trees, the land also doesnt support any farms which of course means the AI cant build anymore Soldiers after his beer(10) from his HQ is used up.*slow clap* sick job Blue Byte.

---> So if you want a better map you gotta change the ground tiles under the 2nd AI's land to fix it.

The original mission had no harbor spots, but tells you at the start that there are. So they intended to have some but never implemented them.
I personaly dont like the harbor spots on this map, i'd prefer if the 2nd AI was able to get the recourses from the lower left by removing the restricted area(thus making him much stronger, the map has already enough recourses to beat both).And for the player to be able to reach the recourses just south of your spawn. Also im pretty sure you were intended to go there without a ship. In the mapeditor it shows you would be able to build a pathway downwards which you actually cant ingame and there is quite amount of gold down there.

Editiert von KaioKen am 05.11.2017 16:33

Spike am 05.11.2017 16:47 #14723

Im Ruhestand
I disagree in changing the original gameplay. Our target with those missions is not to improve them but recreate them.

Maybe one could add alternative versions but the basic version should be just like the original - thats my opinion.

---



KaioKen am 05.11.2017 19:01 #14724


You're right, we shoundt change the original gameplay. Does that mean in your opinion we shoundt add the harbor sports since they were not in the original?
Also changing the ground woundt change any gameplay mechanics for the player, it just woundt make the AI suck or do you disagree on the farms with me?


Spike am 05.11.2017 20:11 #14725

Im Ruhestand
Yes I think so. In my opinion the campaign should feel as the original. I think they may had a balancing problem in Mission 9 so they
just weakened one enemy. We may add a custom, balanced version instead, what about that?

Also the AI is better than it was in the original.

---



KaioKen am 05.11.2017 20:48 #14726


Got it, I agree. Maybe you could make a better version or hard mode version of the campaign someday in the future.

Well, changes for the mission IX - The grey island would be:

1)Reverted the colours to the original(Yellow left--Red right)

2)Changed the restrictions of the lua script to give the red AI a bit more space

3)Made the "Winning Gate/Arc" spawn at the right position when winning at (x-127  y-48) and not in the ocean

---> https://drive.google.com/file/d/0B-GRYdJITblndGVDVWJjSFZiUjQ/view?usp=sharing


~Holzi am 03.12.2017 17:21 #14765


There is a small typo in Mission 2, Initial contact -> MISS201.lua
There needs to be space between "auch von" in "nnDer Mann berichtete uns auchvon Ruinen, die er aufnder"

If I want it to correct myself then map failed to load afterwards.


Holzi85 am 03.12.2017 21:45 #14766


Solved my map loading problem, so all fine. :)


KaioKen am 04.12.2017 14:43 #14768


Cool beans, but i dont know if any1 actually still updates these. It seems crazyL isnt on it anymore. So the things i uplaoded arent in the original post downlaods :/


Holzi85 am 04.12.2017 16:56 #14769


I downloaded your corrected versions of the maps. :)


Strawberry93 am 01.01.2018 15:01 #14827

KaioKen am 01.01.2018 21:14 #14830


Well, i'd like to help but i cant make out what your picture is supposed to show since its only 120x120. Upload a larger version and/or tell me whats going on


Strawberry93 am 02.01.2018 02:33 #14831

KaioKen am 02.01.2018 15:52 #14832


Hmm,I would like recreate this but i didnt manage to do so. Firstly the reason the borders look odd is because there is a restricted area set by the script which disallows the AI to build there, however it is possible for the AI to claim the land but only by capturing your building. Normally this would look like this https://imgur.com/a/qkFlK you can also see the restricted area in red. Tell me what happended? did you reclaim the building a couple of times maybe? Did the borders looked like this from the start when he captured it or did they change over time/ by somehow updating the borders in the area?
Also why is your enemy purple? there are only 2 enemys should be either red or yellow

Editiert von KaioKen am 02.01.2018 19:00

Flamefire am 02.01.2018 19:41 #14833


And for problems like that, please always include the mission files you used and a replay so we can reproduce this. :)

---
Github: https://github.com/Flamefire


~Gast am 04.11.2018 13:50 #15065


Hey Guys,

i have a Problem with the Campaign V.
The Map doesn't start with the Script. I tried to download the lua a second time, but it didn't help to fix my problem.
Each other Map with script starts as it should.

I got this message:
SERVER: Using gameframe length of 50 milliseconds
SERVER: Using networkframe length of 1 GFs (50 milliseconds)
Lua error: ...rsErikSaved GamesReturn To The RootsMAPS/MISS204.lua:367: attempt to index global 'eState' (a nil value)
terminate called after throwing an instance of 'LuaExecutionError'
  what():  ...rsErikSaved GamesReturn To The RootsMAPS/MISS204.lua:367: attempt to index global 'eState' (a nil value)

Is there any Solution?


~Holzi am 04.11.2018 14:25 #15066


Got the same error. Anyone able to fix it? @Flamefire, @Spike


Spike am 05.11.2018 22:18 #15067

Im Ruhestand
Sadly it's a lua bug not a script bug - one may work around but better wait for a fix. If you want to play just remove the "onOccupied"
function. In this case this will just block the final message and your opened gate ;)

https://github.com/Return-To-The-Roots/s25client/issues/910

---



etother am 09.11.2018 12:25 #15079


Thanks for the fix.
I updated my Nightly and it worked :)


~Holzi am 10.11.2018 10:52 #15080


Is there any updated Nightly build available?


etother am 10.11.2018 11:39 #15081


You need to start the s25update.exe in your game folder. Then it should work properly.


Holzi85 am 10.11.2018 16:28 #15082


That worked. Thanks!


etother am 17.11.2018 12:15 #15083


In Campaign 7 there is no defined start position for player 2. The Map didn't start for me.

"Spieler 2 besitzt keine gültige Startposition!server state changed to stop
client state changed to stop"


~Gast am 25.06.2019 09:26 #15249


Hi,

I'm currently playing 3rd mission and something is wrong. Don't know if it is problem with my settings or not. At the beginning AI in
the north is starting to build some houses etc. but aftef few minutes (i can see it in the general statistics) is loses part of his
territory. Then if I approach him, I will be able to see what's in the HQ and capture his territory without destroying HQ.

Another question - is there any progress with these maps beign equal original from S2 GOLD? Any ETA for implementing it to
,,Campaign'' menu?

Cheers


etother am 23.09.2019 15:14 #15294


Does anyone still working on the Lua's?


Spike am 02.01.2020 13:31 #15367

Im Ruhestand
EDIT: Updated all mapfiles and script files.

They now support english and german (will default to english).
https://github.com/Spikeone/RttR_Campaigns

---


Editiert von Spike am 18.01.2020 15:51

~Dan am 04.07.2020 20:25 #15517


Hi Spike,

It's awesome to see that the original campaign seems to be available at:
https://github.com/Spikeone/RttR_Campaigns/tree/master/Campaign_OriginalRoman

But I'm not sure how to play it. In the game the Campaign option is still marked as "Coming Soon". How do I integrate those files into my installation of RttR?


Spike am 04.07.2020 23:20 #15518

Im Ruhestand
Hey Dan,

simply download the repository - then copy all map files into any world folder that is used by RttR.

I recommend overwriting the content of the original MAPS folder.

Now you can select the maps in the singleplayer menu (depending on the folder you put the maps into, if MAPS was chosen, you'll find
them in the Campaign folder).

That should work ;)

---



~Dan am 04.07.2020 23:53 #15519


Hi Spike,

thanks for getting back so quickly. I just replaced the original Maps (from my S2 Gold CD that I had earlier copied to S2/DATA/MAPS) with the content of Campaign_OriginalRoman.
Now when I try to go to "Endlosspiel" (Kampagne is still marked as coming soon) and then select "Kampagne", and then select the first map ("Off we go", I get "Das Lua-Script wurde gefunden,
konnte aber nicht geladen werden. Die Karte könnte nicht wie erwartet funktionieren".
When I try to start the game anyway it starts but not as expected (e.g. no diary messages, all building types are available from the beginning, etc). Also is my headquarter not like expected a
tent but a fancy building.

Let me know if there is anything I might be doing wrong or if I need to us the latest nightly release (currently I use 0.8.2).

Thank you!

Dan


Spike am 05.07.2020 09:27 #15520

Im Ruhestand
Yeah, the button wont change ;)

And you have to updated your version, please use the latest nightly build - version 0.8. is fairly old^^

---





Feel free to post in English!

Antwort schreiben

Username:
Security code:
Text:

   
  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?