RM1985 am 03.09.2017 11:38 #14642

After installing RTTR again, after I got my new PC, I also downloaded the editor again and it was said, that I should replace the existing SDL.dll file with the one coming with the editor. So I did, BUT since then I have no sound in RTTR!

It doesn't even recognize my Sound Drivers. Only Thing I can do so far is using BOTH SDL.dll files and always rename them to have the right one named SDL.dll and the other like SDL1.dll and switch back and forth.

But there must be another solution! I think I had this problem before a couple of years ago and I know it was fixed somehow, cause the last versions I played worked just fine! I had only one SDL.dll file, the one from the editor, and had no Sound problems.

Can someone help me with this??

S2-Freak auf dem Weg zum Titelträger

Spike am 03.09.2017 22:22 #14643

Im Ruhestand
I don't think there is a solution other than using one folder for RttR and one for the editor.


RM1985 am 04.09.2017 17:56 #14646

But it was working before, why now no more??

Maybe I just keep it the way I do it now with renaming the certain SDL.dll file. Cause if I had two different folders I always had to copy the maps back into RTTR to play or test them.

Could I maybe change the path in the editor (RTTR/WORLDS) or must it always be in the same folder?

S2-Freak auf dem Weg zum Titelträger

Flamefire am 08.09.2017 02:30 #14649

Updating the editor to make it work along RTTR is on our TODO. They use different versions of the SDL library which is why they cannot be used at the same time. It might have worked ages ago when RTTR was using the same old version


Feel free to post in English!

Antwort schreiben

Security code:

  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?