~Tycoon51 am 13.05.2018 12:03 #14945

I've recently started FANpaign for S2 Gold (I'm using DosBox), but everytime my empire is large enough, my soldiers don't fill the
military buildings, regardless the military settings. I have some fortresses on the enemy border (with X flag), and a storehouse next
to them with over 30 soldiers, but in the fortresses are just around 4 of them. I've tried to pull back and forth the military settings
for all buildings, but I can't manage to move the soldiers from storehouse to the fortresses.

Second issue occurs too with large empire, that not all new roads are being occupied by peasants, and therefore transport problems
occur. Items just start to stuck on the crossroads because there is no one to transport them through the roads. Again, I have plenty of
peasant in storehouses, but the don't occupy the roads.

I've finally managed to start of the first two mission of campaign, but the maps are huge and I'm quickly being limited by these bugs.
They are probably caused by limitations of the game's engine. I'm not running into any performance nor framerate problems.

I wonder if there's any workaround for these issues, since there's no campaign support in RttR and it's playable only in original game.

Leuchtefix75 am 14.05.2018 00:40 #14949

You are playing Settler2 Gold by BlueByte in a DosBox, OK.

This is Return-to-the-Roots by SettlersFreaks, called s25client, a rewrite of the game engine.
To get a copy of it, go to Downloads and select the System and Architecture of your computer and klick the Download link "RttR Server".
Unpack it.
In the game directory you should find a file named "put your S2-Installation in here", which means in the same folder.
So copy the DATA and GFX folder of the original Settlers2 Gold edition in there.
Play s25client !

Singleplayer => Unlimited Play => Campaign

Yes, there are several issues, but the s25client was intended for player vs. player
and still is open source.

Editiert von Leuchtefix75 am 14.05.2018 01:38

FloSoft am 14.05.2018 18:35 #14951


I wonder if there's any workaround for these issues, since there's no campaign support in RttR and it's playable only in original game.

Well, I'm sorry but the only workaround for the old game I know is to reduce streets. Remove everything unneeded, make street paths longer, etc. I think there seems to be an internal limit after that the pathfinding in the old S2 breaks.
Since we are NOT BlueByte, we can't (and won't) fix anything in the old S2.

Yes the campaign support in RttR is very limited at the moment, but you can play a lot of Skirmish Maps and you can even play the original campaign maps (without "Questline") via Singleplayer - Unlimited Play - Campaign (like Leuchtefix already said)


~Tycoon51 am 15.05.2018 15:51 #14954

Thank you for your replies.

I have already the RttR installed, and I already have tried to play through this campaign with RttR, but I can only load the maps, but
the campaign strongly relies on other things like different starting goods, diplomacy etc. and these (as far I know) are not easily
transferable from old files to the new RttR engine.

The street reduction might work, I will try it for sure. I usually build as many streets as possible to get maximal throughput, and
that can be the issue.

Feel free to post in English!

Antwort schreiben

Security code:

  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?