~Erik am 12.04.2019 12:15 #15203


When trying to follow the 'How to build' guide
for Windows here:

At the part about setting up boost it says to
run the bootstrap.exe which then creates
b2.exe. Bootstrap doesn't create b2.exe with a
message in the error log that it was unable to
find vswhere.

Do you know how to fix that?


Flamefire am 12.04.2019 18:52 #15204

Hi. Can you please provide some more information:

- version of boost
- version of visual studio installed
- exact error message with a bit of relevant context

Besides: As this is an issue with boost, did you try to google it?


~Erik am 13.04.2019 12:43 #15206


Sure thing :)

- version of boost:

I tried with both 1_69_0 and 1_64 as in the Git guide.

- version of visual studio installed:

From vswhere:
displayName: Visual Studio Community 2019
installationVersion: 16.0.28803.156

- exact error message with a bit of relevant context:

After running bootstrap.bat a bootstrap.log is created with the following message:

could not find "vswhere"
### Using 'msvc' toolset.

C:UsersErikDesktops25clientexternalboost_1_69_0toolsbuildsrcengine>if exist bootstrap rd /S /Q bootstrap

C:UsersErikDesktops25clientexternalboost_1_69_0toolsbuildsrcengine>md bootstrap

C:UsersErikDesktops25clientexternalboost_1_69_0toolsbuildsrcengine>cl /nologo /GZ /Zi /MLd /Fobootstrap/ /Fdbootstrap/ -DNT -
DYYDEBUG kernel32.lib advapi32.lib user32.lib /Febootstrapjam0  command.c compile.c constants.c debug.c execcmd.c execnt.c filent.c
frames.c function.c glob.c hash.c hdrmacro.c headers.c jam.c jambase.c jamgram.c lists.c make.c make1.c object.c option.c output.c
parse.c pathnt.c pathsys.c regexp.c rules.c scan.c search.c subst.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c
md5.c class.c cwd.c w32_getreg.c native.c modules/set.c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c

C:UsersErikDesktops25clientexternalboost_1_69_0toolsbuildsrcengine>exit /b 9009
The message is formatted by this forum for some reason removing back slashes.

- did you try to google it?:

I did, but couldn't find anything.

Flamefire am 13.04.2019 13:54 #15207

So far there is no error, just a warning. Is there nothing else in the console? Like "file not found" or so?

The ' could not find "vswhere"'  is not critical although it would probably be best if it was found. Am I right in assuming you did install it?

If so try the following:

- Open a new command prompt inside the boost folder
- make sure 'vswhere' is found by trying to execute it: `vswhere /?` (or so)
- If it isn't put it into your PATH or adjust the PATH variable, then reopen the command prompt
- run bootstrap from this command prompt

If all this fails, open a Visual Studio Developer prompt (start menu), navigate to the boost folder, then execute bootstrap etc.


~Erik am 14.04.2019 20:17 #15208


- Am I right in assuming you did install it?:
Well, I am just following the guide to build for Windows on your git page step by step.
I didn't install vswhere as it is not mentioned there, but I did install Visual Studio.

- If all this fails, open a Visual Studio Developer prompt (start menu), navigate to the boost folder, then execute bootstrap etc.:
This worked! The b2.exe got built.

Next I tried to run b2.exe from the VS develpoer console and got the following error message:
error: Name clash for '<pstagelib>libboost_python27-vc-mt-1_69.lib'
error: Tried to build the target twice, with property sets having
error: these incompatible properties:
error:     -  <address-model>32
error:     -  <address-model>64
error: Please make sure to have consistent requirements for these
error: properties everywhere in your project, especially for install
error: targets.

Know what that is?

By the way thank you for trying to help me on this. I know this is an old git and an even older game! But it's solid :)

Flamefire am 14.04.2019 21:08 #15209

Simple solution: Exclude the python libs from boost build by adding `--without-python`

Better: Choose which version of RttR you want and build the appropriate boost by using `address-model=64` (no --)


~Erik am 18.04.2019 08:07 #15215


Ok, so now I managed to install b2.exe with the following command line in the VB developer console:
b2.exe --without-python address-model=64 --prefix=%CD%

Next step was the cmake-gui.
After following the guide on the git page it started compiling, but stopped with the error message:
'Error in configuration process, project files may be invalid'.
In my target path there is a CMakeError.log file with 13 various fatal errors.

Here are a few examples:
'fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory'
'fatal error C1083: Cannot open include file: '/var/lib/oss/include/sys/soundcard.h': No such file or directory'
'fatal error C1083: Cannot open include file: '/usr/local/lib/oss/include/sys/soundcard.h': No such file or directory'

Any idea what might be wrong here?


Flamefire am 19.04.2019 18:24 #15218

If you use Cmake-gui there should be some red text in the output pane which should tell you what is wrong.

The errors quoted are ok: CMake detects whether those headers are available by trying to compile using them. "Fatal error" => "not available"


~Erik am 28.04.2019 20:22 #15224


There are a lot of red texts in the pane.

First one is:
"CMake Warning at cmake/Modules/CheckGitSubmodules.cmake:4 (message):
  Git could not be found.  You have to manually make sure all sources and
  submodules are available.
Call Stack (most recent call first):
  CMakeLists.txt:34 (check_git_submodules)"

All the subsequent ones are about being unable to find various Boost libraies.

Leuchtefix75 am 28.04.2019 23:07 #15225

build boost with a lot of warnings, type:
...std::auto_ptr’ is deprecated
...declared here   template<typename> class auto_ptr

but that's OK

so I end up with CMAKE message on s25client:
Imported targets not available for Boost version 106400

boost/version.hpp => #define BOOST_VERSION 1.64.0
=>don't solve the issue

How about a build without boost?

And how do I start the game server without a client?

Editiert von Leuchtefix75 am 29.04.2019 18:24

Flamefire am 03.05.2019 12:13 #15227

Git could not be found.

You don't have git in the PATH. Didn't you use git to checkout the source? You can create a new environment variable called "CMAKE_PREFIX_PATH", find the path to "git.exe" and add it (without the "bin" dir) to the "CMAKE_PREFIX_PATH" (so if it is C:foobarbingit.exe then CMAKE_PREFIX_PATH=C:foobar)
This is not required but makes sure you have the correct submodules.
All the subsequent ones are about being unable to find various Boost libraies.  

Where did you install boost to? If you used the "--prefix=%CD%" then in which folder were you? Add that to CMAKE_PREFIX_PATH too (separated by colon [or semicolon, not entirely sure for windows])
Imported targets not available for Boost version ...

Update cmake to a newer version supporting that boost version. In this case not required as CMake 3.8 already supports our minimum required version (1.64)
How about a build without boost?

Not possible
And how do I start the game server without a client?  

Not possible


Editiert von Flamefire am 03.05.2019 12:14

Leuchtefix75 am 05.05.2019 23:07 #15229

You think, writing the whole game engin from ground up new,
is not a thing you would like to do next time, right? ;)

OK, if there is no BOOST 1.64, don't install any Boost, download the source, build, install it... after you did the same to
CMAKE 3.8.
got it!

You remember the several memory issues I'm facing, running the game?
Could you spend a thought on this error message?

SERVER: Reserved slot 0 freed due to timeout

corrupted double-linked list

...then trying to access a value from?

Editiert von Leuchtefix75 am 06.05.2019 01:39

Feel free to post in English!

Antwort schreiben

Security code:

  Convert smilies like :), ;) etc. into small graphics?
  Convert WWW-addresses into clickable links?
  Soll Boardcode in ihrer Nachricht aktiviert werden?