Forum



FloSoft am 24.12.2010 11:15 #6481

Großmeister
Hallo,

wir sind stolz ankündigen zu dürfen, es endlich doch noch geschafft zu haben, eine neue stabile Version zu veröffentlichen :-)

Die Version 0.7 von Return To The Roots steht nun unter Downloads zur Verfügung.

Da doch einige Fragen bzgl "MSVCP100.dll" gekommen sind:
Um diesen Fehler zu beheben müsst ihr entweder den Installer benutzen, oder

https://www.microsoft.com/downloads/en/details.aspx?familyid=A7B7A05E-6DE6-4D3A-A423-37BF0912DB84&displaylang=en

manuell installieren.

Wichtig ist auch: BITTE NICHT ÜBER EINE NIGHTLY INSTALLIEREN!
Das wird nicht funktionieren.

Achja: Frohe Weihnachten ;-)

---
mfg
Flo


Editiert von FloSoft am 24.12.2010 23:22

HeXor am 24.12.2010 22:13 #6488


Da sitze ich an heilig Abend zu Hause und schwelge ein wenig in Nostalgie und da fallen mir die alten Sieder2 CDs in die Hand die ich prompt in mein CD Laufwerk gelegt habe und installiert habe. Dann bin ich wie üblich auf die Probleme gestoßen die man bekommt, wenn man ein uraltes Spiel auf den neuen Betriebssystemen spielen will, also suche ich bei google nach Lösungen für das Problem.

Auf einmal lese ich etwas von einem Revival des Klassikers, wo sich ein paar Leute zusammen tun, viel Arbeit investieren und diesen Klassiker wieder aufleben lassen.

Leute, ich DANKE euch! Ihr habt mir heute Abend das schönste Weihnachtsgeschenk gemacht. Ich habe eben kurz in die erste Kampagne reingespielt und bin begeistert. Ich brauche keine Zusatzsoftware und nichts und es läuft einwandfrei. Ab sofort werde ich regelmäßig hier vorbeischauen! Ihr leistet großartige Arbeit! Ich kenne noch ein paar Siedler2 Nostalgider die ich direkt mal auf euch aufmerksam machen werde!

Frohe Weihnachten euch allen und nochmals RIESEN DANK!


NastX am 25.12.2010 17:04 #6494


Na dann ist das doch das Perfekte Weihnachtsgeschenk (= So also momentan geht die Lobby nicht aber das sollte in ein paar Stunden behoben sein (wenn das alles klappt), wer trotzdem nach Spielern sucht oder Probleme hat, der möge einfach mal in den Chat kommen.

---
>> Du programmierst doch auch Perl, wie wärs denn mit einem
>> Verbesserungsvorschlag (kürzer, speicherschonender, gleiche
>> Funktionalität, ...)?

Kein Perl.


Siegfried am 25.12.2010 18:45 #6497


So, das ist herrlich. Passend zu Weihnachten ein neuer Meilenstein :)


Thrillkilla am 30.12.2010 00:25 #6518


Servus,
Ich wollte mal fragen warum ich das teil nich starten/installieren kann?
Ich hab das redist pack runtergeladen von microsoft.
Jedoch kommt die Fehlermeldung das eine "libbz2.dll" nicht vorhanden ist.
Also gegooglet und schnell gezogen. In System32 und ins Spielverzeichnis geschoben.
Jetzt kommt s25client.exe funktioniert nicht mehr. :/
Bitte um schnelle Hilfe.

---
Hardstyle forever N bisschen was von mir :D :
http://www.youtube.com/watch?v=7Fa15Ixihwk
Siedler 2


Thrillkilla am 30.12.2010 01:31 #6519


Offtopic. Ich kann nich editieren... :(
Ich hab jetzt noch n bisschen rumprobiert und habs zum laufen gebracht.

---
Hardstyle forever N bisschen was von mir :D :
http://www.youtube.com/watch?v=7Fa15Ixihwk
Siedler 2


Manauii am 31.12.2010 13:00 #6526


Zitat von Thrillkilla:

Ich hab jetzt noch n bisschen rumprobiert und habs zum laufen gebracht.

Was war denn die Lösung? Das gleiche Problem habe ich nämlich auch gerade.


Thrillkilla am 02.01.2011 11:03 #6528


Puuh...
Also hab den Ordner GFX und DATA von meim original Siedler 2 Gold genommen...
In nen Neuen Ordner reingepackt...
Dann die ganzen Sachen wie beschrieben reingehauen und im update Ordner die "s25update.exe" gestartet..
Das dauert dann in etwa 10 Minuten, aber dann müsste es laufen :D

---
Hardstyle forever N bisschen was von mir :D :
http://www.youtube.com/watch?v=7Fa15Ixihwk
Siedler 2


drei4 am 03.01.2011 18:08 #6542


Sehr gut! Werd's gleich ausprobieren.


DIDDL am 07.01.2011 20:47 #6558


Hi

Habe da ein problem mit dem neuen 0.7 build.
Habe den data und gfx kopiert nun wollte ich starten geht aber nicht, folgender fehler kommt:
Der Prozedureinsprungpunkt"_invalid_parameter_noinfo_noreturn" wurde in der DLL "MSVCR100.dll" nicht gefunden.
Was kann ich da machen?
Bitte bitte helft mir.

mfg
DIDDL


DIDDL am 07.01.2011 21:07 #6559


Hi

Habe da ein problem mit dem neuen 0.7 build.
Habe den data und gfx kopiert nun wollte ich starten geht aber nicht, folgender fehler kommt:
Der Prozedureinsprungpunkt"_invalid_parameter_noinfo_noreturn" wurde in der DLL "MSVCR100.dll" nicht gefunden.
Was kann ich da machen?
Bitte bitte helft mir.

mfg
DIDDL


Spike am 07.01.2011 21:10 #6560

Im Ruhestand
Der Link von flo auf seite 1 wegen einer ähnlichen datei schafft dabei auch keine abhilfe?

---



DIDDL am 07.01.2011 21:22 #6561


Zuerst hatte ich ja den fehler mit MSVCP100.dll. Dann habe ich mir das pack von MS (vom angebotenen link) geladen und ab da habe ich den genanten fehler.


DIDDL am 07.01.2011 21:55 #6562


Zuerst hatte ich ja den fehler mit MSVCP100.dll. Dann habe ich mir das pack von MS (vom angebotenen link) geladen und ab da habe ich den genanten fehler.


Spike am 07.01.2011 22:08 #6563

Im Ruhestand
Und wenn du die die .dll einfach iwo im internet runterlädst und diese dann in dein spielverzeichnis kopierst? das müsste doch helfen oder nicht?

---



DIDDL am 07.01.2011 22:13 #6564


Naja im moment startet die s25client.exe. Da gibt es aber schon wieder probleme.
Es öffnen sich ja 2 fenster und in dem einen steht drin das es nicht installiert ist unter J:\Programme...
Ich habe aber kein J


Spike am 08.01.2011 11:20 #6565

Im Ruhestand
hast du dir die nightly oder die 0.7 runtergeladen? als installationspaket oder zum kopieren?

so ich versuch das mal wie nastx :S

---------------------------------------------------------------------------------------------

have you downloaded the nightly or the 0.7? And had you to install the game or just to copy the files to your folder?

---



DIDDL am 08.01.2011 14:34 #6566


ich habe die 0.7 einmal als zip und einmal als installation probiert. geht nicht.


wutz am 14.01.2011 19:42 #6597


hallo

ich habe da ein problem das ich einfach nicht lösen kann.
Das spiel startet und funktioniert auch soweit einwandfrei nur
nach ca 3 stunden/beim ersten kontakt mit dem gegener stürzt es ab und man is wieder bei windows.
Wenn man versucht das spiel zu laden dann nach kurzer zeit das gleiche wieder. Nach ewigen rumprobieren wurde es zwar nicht besser aber es kahm ne fehlermeldung s25CLIENT HAT EIN PROBLEM FESTGESTELLT UND MUSS BEENDET WERDEN. fertig :/

bitte um hilfe


wutz am 14.01.2011 19:52 #6598


hallo

ich habe da ein problem das ich einfach nicht lösen kann.
Das spiel startet und funktioniert auch soweit einwandfrei nur
nach ca 3 stunden/beim ersten kontakt mit dem gegener stürzt es ab und man is wieder bei windows.
Wenn man versucht das spiel zu laden dann nach kurzer zeit das gleiche wieder. Nach ewigen rumprobieren wurde es zwar nicht besser aber es kahm ne fehlermeldung s25CLIENT HAT EIN PROBLEM FESTGESTELLT UND MUSS BEENDET WERDEN. fertig :/

bitte um hilfe


wutz am 14.01.2011 19:59 #6599


hallo

ich habe da ein problem das ich einfach nicht lösen kann.
Das spiel startet und funktioniert auch soweit einwandfrei nur
nach ca 3 stunden/beim ersten kontakt mit dem gegener stürzt es ab und man is wieder bei windows.
Wenn man versucht das spiel zu laden dann nach kurzer zeit das gleiche wieder. Nach ewigen rumprobieren wurde es zwar nicht besser aber es kahm ne fehlermeldung s25CLIENT HAT EIN PROBLEM FESTGESTELLT UND MUSS BEENDET WERDEN. fertig :/

bitte um hilfe


Spike am 14.01.2011 20:18 #6600

Im Ruhestand
naja, du müsstest ja ein replay haben genau zu der stelle an der es crasht, das müsste du dann im bugtracker reporten und dann kann sich jemand dem problem annehmen.

---



DIDDL am 14.01.2011 21:55 #6603


Hat keiner ne lösung für mein problem?


HarryHirsch123 am 14.01.2011 21:59 #6606


welches problem?


HarryHirsch123 am 14.01.2011 21:59 #6607


ach das naja ich hab kein windows


FloSoft am 15.01.2011 08:36 #6609

Großmeister
DIDDL, hast du evtl ein 64bit system und dann auch "nur" das vc-redist der 64bit version installiert? du musst das 32bit vc-redist jedoch installieren, egal ob du 64bit oder 32bit windows hast

---
mfg
Flo



HarryHirsch123 am 15.01.2011 10:28 #6610


Ach äh wutz bnenutzt due die 0.7?
lade dir mal lieber die nightly


wutz am 15.01.2011 15:05 #6614


ja ich benutz die 0.7.
ok werd ich machen danke!


HarryHirsch123 am 15.01.2011 15:13 #6615


also die 0.7 hat ein paar bugs die bei der nightly nicht sind.
z.b. mit der eselzucht.

Editiert von SiedlerFreak am 16.01.2011 14:20

Spike am 15.01.2011 21:49 #6622

Im Ruhestand
naja, die 0.7 hat ebend weniger leistungsverbrauch im gegensatz zu den nightlys^^

---



HarryHirsch123 am 16.01.2011 10:32 #6624


Naja das stimmt auch wieder

Editiert von SiedlerFreak am 16.01.2011 14:20

DIDDL am 17.01.2011 00:34 #6634


Zitat von FloSoft:

DIDDL, hast du evtl ein 64bit system und dann auch "nur" das vc-redist der 64bit version installiert? du musst das 32bit vc-redist jedoch installieren, egal ob du 64bit oder 32bit windows hast


Ich habe WinXP Home 32 bit, habe das vc-redist auch installiert


DIDDL am 09.02.2011 21:10 #6783


Kann mir wirklich niemand hier helfen? Bekomme immer diesen fehler:

lade "L:/Eigene Dateien/My Games/Siedler II.5 RttR/CONFIG.INI": fertig (0ms)
searching for drivers in ./driver/video/*.dll
2 video drivers found!
searching for drivers in ./driver/audio/*.dll
1 audio drivers found!
schreibe "L:/Eigene Dateien/My Games/Siedler II.5 RttR/CONFIG.INI": fertig

Starte das Spiel
Fehler: Datei oder Verzeichnis "J:/Programme/BlueByte/SIEDLER2/GFX/PALETTE/PAL5.BBM" existiert nicht.
              
WIESO VERSUCHT ER IMMEER AUF J:/PROGRAMME zuzugreifen?

ERROR: Einige Dateien konnten nicht geladen werden.
Stellen Sie sicher, dass die Siedler 2 Gold-Edition im gleichen
Verzeichnis wie Return to the Roots installiert ist.


ERROR: Some files failed to load.
Please ensure that the Settlers 2 Gold-Edition is installed
in the same directory as Return to the Roots.


ERROR: Das Spiel konnte nicht gestartet werden


Drcken Sie eine beliebige Taste . . .
>>> NMS_DEAD_MSG


DIDDL am 09.02.2011 21:38 #6784


Habe jetzt alles noch mal neu gemacht und auch das update erneut lauffen lassen.
Habe als die FW mich fragte zullassen ja oder nein habe ich Ja gedrückt und trozdem kommt folgender fehler:

server state changed to stop
Fehler beim Verbinden mit localhost:3665
GameClient::Connect: ERROR: Connect failed!
searching for drivers in ./driver/video/*.dll
searching for drivers in ./driver/audio/*.dll
schreibe "L:/Eigene Dateien/My Games/Siedler II.5 RttR/CONFIG.INI": fertig
Automatisches Erstellen des Portforwardings mit UPnP fehlgeschlagen
Fehler: Schnittstelle nicht unterstützt

server state changed to stop
Fehler beim Verbinden mit localhost:3665
GameClient::Connect: ERROR: Connect failed!
Automatisches Erstellen des Portforwardings mit UPnP fehlgeschlagen
Fehler: Schnittstelle nicht unterstützt

server state changed to stop
Fehler beim Verbinden mit localhost:3665
GameClient::Connect: ERROR: Connect failed!
schreibe "L:/Eigene Dateien/My Games/Siedler II.5 RttR/CONFIG.INI": fertig
Saeubere Texturespeicher: fertig (nach 0ms)

Drcken Sie eine beliebige Taste . . .
>>> NMS_DEAD_MSG

Gibt es wirklich niemanden der helfen kann?

Editiert von DIDDL am 09.02.2011 22:18

FloSoft am 10.02.2011 09:09 #6788

Großmeister
Hi,

hast du ein komplett frisches Release runtergeladen (also entweder die aktuelle Nightly oder ein 0.7.2 paket?) Dies dann bitte auch in einen frischen Ordner - und dort von der Siedler 2 Gold CD DATA und GFX noch reinkopieren.

Es gibt wohl einige Nightly-Versionen, die sich nicht richtig updaten (warum auch immer ...)

---
mfg
Flo



DIDDL am 10.02.2011 18:35 #6790


Habe die 0.7.2 nochmals geladen und alles so gemacht wie beschrieben.
Nach ein paar versuchen hat es endlich geklappt.
Nun wenn ich im single player spielen will muß ich ja direkt IP anwählen, aber sobald ich eine kampagne oder weld scenario auswähle stürtzt er ab sobalt ich auf weiter gehe.
Ist doch nicht normal oder?


FloSoft am 11.02.2011 13:34 #6791

Großmeister
hi, keine Gold-Version von Siedler II benutzt?

---
mfg
Flo



DIDDL am 13.02.2011 03:04 #6800


Na klar habe ich die Gold Version benutzt


FloSoft am 13.02.2011 13:07 #6801

Großmeister
Hi,

das spiel legt eine Log-file bei jedem Start an (Eigene Dateien\My Games\... bzw Saved Games\... unter win7/vista) schau dort mal was die letzten zeilen melden bevor es abstürzt - achja - mach am besten nen neuen thread auf - danke

---
mfg
Flo